summaryrefslogtreecommitdiff
path: root/os/Makefile.am
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-10-17 07:18:59 +0000
committerKevin E Martin <kem@kem.org>2005-10-17 07:18:59 +0000
commit1859c62607d567aa05334df1662f7249c983f793 (patch)
treea5905411c6a734e9d968e172324cd3430100e1fd /os/Makefile.am
parentccfe9e7e9b49cbbf7c50fbf1a5c33178f27f79eb (diff)
include/dix-config.h.in Add support for more extensions
Add missing files to EXTRA_DIST
Diffstat (limited to 'os/Makefile.am')
-rw-r--r--os/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/os/Makefile.am b/os/Makefile.am
index 706f50539..105489972 100644
--- a/os/Makefile.am
+++ b/os/Makefile.am
@@ -2,12 +2,10 @@ noinst_LTLIBRARIES = libos.la
AM_CFLAGS = $(DIX_CFLAGS)
-# k5auth.c \
-# rpcauth.c \
-# genalloca.c \
-# hpsocket.c \
-# secauth.c
-# xalloc.c
+# FIXME: Add support for these in configure.ac
+K5AUTH_SOURCES = k5auth.c
+SECURERPC_SOURCES = rpcauth.c
+INTERNALMALLOC_SOURCES = xalloc.c
if XCSECURITY
XCSECURITY_SOURCES = secauth.c
@@ -41,3 +39,5 @@ libos_la_SOURCES = \
$(XDMCP_SOURCES) \
$(XORG_SOURCES) \
$(LBX_SOURCES)
+
+EXTRA_DIST = $(K5AUTH_SOURCES) $(SECURERPC_SOURCES) $(INTERNALMALLOC_SOURCES)