summaryrefslogtreecommitdiff
path: root/xc/extras/Mesa/book/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xc/extras/Mesa/book/Makefile.am')
-rw-r--r--xc/extras/Mesa/book/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/xc/extras/Mesa/book/Makefile.am b/xc/extras/Mesa/book/Makefile.am
new file mode 100644
index 000000000..3a459775b
--- /dev/null
+++ b/xc/extras/Mesa/book/Makefile.am
@@ -0,0 +1,29 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies
+
+INCLUDES = -I$(top_srcdir)/include $(GLUT_CFLAGS)
+
+check_PROGRAMS = aaindex aapoly aargb accanti accpersp alpha alpha3D anti \
+ bezcurve bezmesh checker clip colormat cube depthcue dof \
+ double drawf feedback fog fogindex font hello image light \
+ lines list material mipmap model movelight nurbs pickdepth \
+ picksquare plane planet polyoff polys quadric robot sccolorlight \
+ scene scenebamb sceneflat select smooth stencil stroke surface \
+ teaambient teapots tess tesswind texbind texgen texprox texsub \
+ texturesurf torus trim unproject varray wrap
+
+EXTRA_DIST = jitter.h
+
+LDADD = $(GLUT_LIBS) $(top_builddir)/src-glu/libGLU.la \
+ $(top_builddir)/src/libGL.la -lm
+LDFLAGS = -no-install
+
+# execute all programs
+exec: $(check_PROGRAMS)
+ @for prog in $(check_PROGRAMS); \
+ do \
+ echo -n "Running $$prog ..." ; \
+ ./$$prog ; \
+ echo ; \
+ done