summaryrefslogtreecommitdiff
path: root/hw/xfree86/dri/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-12-14 14:18:58 -0800
committerDan Nicholson <dbn.lists@gmail.com>2009-01-18 09:49:06 -0800
commite1c8ee215797fa8c6a3a5421bb6f99b58064248b (patch)
tree7747a213440c086ad8c8aa281def354ca2abe009 /hw/xfree86/dri/Makefile.am
parentca46c01869768a8661a9d8a71493ed5f0760a8ab (diff)
Don't reuse PKG_CHECK_MODULES identifiers
Using GL for the PKG_CHECK_MODULES identifier multiple times means only the first call will actually be used. Later calls will be skipped due to GL_CFLAGS and GL_LIBS already being set. This changes DRI to using a different identifier and DMX to just reusing GL_CFLAGS. Signed-off-by: Dan Nicholson <dbn.lists@gmail.com>
Diffstat (limited to 'hw/xfree86/dri/Makefile.am')
-rw-r--r--hw/xfree86/dri/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/hw/xfree86/dri/Makefile.am b/hw/xfree86/dri/Makefile.am
index 3ec30beec..9bc8fab0c 100644
--- a/hw/xfree86/dri/Makefile.am
+++ b/hw/xfree86/dri/Makefile.am
@@ -13,7 +13,7 @@ libdri_la_CFLAGS = -I$(top_srcdir)/hw/xfree86/common \
-DHAVE_XORG_CONFIG_H \
@DIX_CFLAGS@ @XORG_CFLAGS@ @DRIPROTO_CFLAGS@ \
@LIBDRM_CFLAGS@ \
- @GL_CFLAGS@
+ @DRI_CFLAGS@
libdri_la_LDFLAGS = -module -avoid-version @LIBDRM_LIBS@
libdri_ladir = $(moduledir)/extensions
libdri_la_SOURCES = \