summaryrefslogtreecommitdiff
path: root/hw/kdrive/ephyr/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <anholt@freebsd.org>2006-03-07 19:57:46 +0000
committerEric Anholt <anholt@freebsd.org>2006-03-07 19:57:46 +0000
commit9d8c0e4bcbb111e860b7c3c33c224c22589006b1 (patch)
treee8838cae87aceb5e98fbac1215ca001da07055cb /hw/kdrive/ephyr/Makefile.am
parent0a3d6c739968bf5af81fc0e8ea7211c20d52080b (diff)
Add a new flag to ephyr, "-fakexa", which turns on an EXA acceleration
implementation that calls fb to get its work done. The purpose is to have a trusted EXA driver for use with testing changes to the core of EXA. However, fakexa has not received much testing yet, lacks offscreen pixmaps support, and doesn't reliably provide garbage when EXA doesn't get its syncing right. All of these should be fixed soon.
Diffstat (limited to 'hw/kdrive/ephyr/Makefile.am')
-rw-r--r--hw/kdrive/ephyr/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/hw/kdrive/ephyr/Makefile.am b/hw/kdrive/ephyr/Makefile.am
index 1cc5e6872..2fb1fc2e5 100644
--- a/hw/kdrive/ephyr/Makefile.am
+++ b/hw/kdrive/ephyr/Makefile.am
@@ -1,6 +1,7 @@
INCLUDES = \
@KDRIVE_INCS@ \
- @KDRIVE_CFLAGS@
+ @KDRIVE_CFLAGS@ \
+ -I$(srcdir)/../../../exa
noinst_LIBRARIES = libxephyr.a libxephyr-hostx.a
@@ -13,6 +14,7 @@ bin_PROGRAMS = Xephyr
libxephyr_a_SOURCES = \
ephyr.c \
+ ephyr_draw.c \
os.c \
hostx.h \
ephyr.h
@@ -32,11 +34,10 @@ Xephyr_LDADD = \
@KDRIVE_LIBS@ \
@KDRIVE_LIBS@ \
$(TSLIB_LIBS) \
- @XEPHYR_LIBS@
-
+ @XEPHYR_LIBS@ \
+ ../../../exa/libexa.la
Xephyr_DEPENDENCIES = \
libxephyr.a \
libxephyr-hostx.a \
@KDRIVE_LIBS@
-