summaryrefslogtreecommitdiff
path: root/hw/dmx/Makefile.am
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-07-12 01:20:36 +0000
committerKevin E Martin <kem@kem.org>2005-07-12 01:20:36 +0000
commit02427d4d04f70109a499578c6762654463ebdae4 (patch)
tree0fa96e475a0c40881319b73c62d6462ec3ad8ae3 /hw/dmx/Makefile.am
parent3fe6b5bb30e8e1b9017a9cf818fcceb279a28e65 (diff)
Add support for building Xdmx and Xvfb
Diffstat (limited to 'hw/dmx/Makefile.am')
-rw-r--r--hw/dmx/Makefile.am56
1 files changed, 12 insertions, 44 deletions
diff --git a/hw/dmx/Makefile.am b/hw/dmx/Makefile.am
index b387a9ffe..9dba2d7c4 100644
--- a/hw/dmx/Makefile.am
+++ b/hw/dmx/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = input
+SUBDIRS = input config
bin_PROGRAMS = Xdmx
if XINERAMA
@@ -30,55 +30,23 @@ Xdmx_SOURCES = dmxinit.c \
dmxstat.c \
dmxsync.c \
dmxextension.c \
- miinitext.c \
dmxpict.c \
- libc_wrapper.c \
+ $(top_srcdir)/fb/fbcmap.c \
+ $(top_srcdir)/Xext/dmx.c \
+ $(top_srcdir)/mi/miinitext.c \
$(GLX_SRCS)
-
#if COMPOSITE
#Xdmx_SOURCES += fakecw.c
#endif
-miinitext.c:
- echo "#include <config.h>" > $@
- echo "#undef HAVE_CONFIG_H" >> $@
- echo "#define DMXEXT" >> $@
- echo "#undef BEZIER " >> $@
- echo "#undef PEXEXT " >> $@
- echo "#undef MULTIBUFFER " >> $@
- echo "#undef XV " >> $@
- echo "#undef XIE " >> $@
- echo "#undef DBE " >> $@
- echo "#undef XF86VIDMODE " >> $@
- echo "#undef XF86MISC " >> $@
- echo "#undef XFreeXDGA " >> $@
- echo "#undef XF86DRI " >> $@
- echo "#undef MITSHM " >> $@
- echo "#undef TOGCUP " >> $@
- echo "#undef DPSEXT " >> $@
- echo "#undef MITMISC " >> $@
- echo "#undef SCREENSAVER " >> $@
- echo "#undef RANDR " >> $@
- echo "#undef XFIXES " >> $@
- echo "#undef DAMAGE " >> $@
- echo "#undef COMPOSITE " >> $@
- echo "#undef FONTCACHE " >> $@
- echo "#undef XFree86LOADER " >> $@
- echo "#include \"$(top_srcdir)/mi/miinitext.c\"" >> $@
-
-DISTCLEANFILES = miinitext.c libc_wrapper.c
-
-libc_wrapper.c:
- echo "#define SELF_CONTAINED_WRAPPER" > $@
- echo "#include \"$(top_srcdir)/hw/xorg/os-support/shared/libc_wrapper.c\"" >> $@
-
-
Xdmx_LDFLAGS = -rdynamic
-Xdmx_LDADD = $(XORG_CORE_LIBS) $(top_srcdir)/hw/xorg/os-support/@XORG_OS_SUBDIR@/lib@XORG_OS_SUBDIR@.a \
- $(XDMX_LIBS) $(GLX_LIBS) $(top_srcdir)/miext/shadow/.libs/libshadow.a $(top_srcdir)/fb/.libs/libfb.a \
- $(top_srcdir)/hw/xorg/dummylib/libdummy.a input/libdmxinput.a \
- config/libdmxconfig.a -lfl $(XDMCP_LIBS) @DMXMODULES_LIBS@ -lXi
-
-Xdmx_CFLAGS = @DMXMODULES_CFLAGS@
+Xdmx_LDADD = $(XORG_CORE_LIBS) \
+ $(XDMX_LIBS) \
+ $(GLX_LIBS) \
+ input/libdmxinput.a \
+ config/libdmxconfig.a \
+ @DMXMODULES_LIBS@
+
+Xdmx_CFLAGS = -DHAVE_DMX_CONFIG_H @DMXMODULES_CFLAGS@ -DXFree86Server