summaryrefslogtreecommitdiff
path: root/dix/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter@cs.unisa.edu.au>2008-04-22 18:04:05 +0930
committerPeter Hutterer <peter@cs.unisa.edu.au>2008-04-22 18:04:05 +0930
commit8190ef87547b704848231bde10b1cdffc6442790 (patch)
tree29cb6d5bdefcee879d103953a140373635726f17 /dix/Makefile.am
parent179a082c26f9e562492ee2e59e7f44f949f39f9c (diff)
parent2ddbfd345786aa39b6ccaed82a1ca5c145284ee3 (diff)
Merge branch 'master' into mpx
Conflicts: Xext/EVI.c Xext/appgroup.c Xext/cup.c Xext/mitmisc.c Xext/sampleEVI.c dix/window.c
Diffstat (limited to 'dix/Makefile.am')
-rw-r--r--dix/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/dix/Makefile.am b/dix/Makefile.am
index 554ab83a9..c24e98530 100644
--- a/dix/Makefile.am
+++ b/dix/Makefile.am
@@ -1,4 +1,10 @@
-noinst_LTLIBRARIES = libdix.la libxpstubs.la
+standard_dix_libs = libdix.la libxpstubs.la
+
+if XPRINT
+noinst_LTLIBRARIES = $(standard_dix_libs) libXpdix.la
+else
+noinst_LTLIBRARIES = $(standard_dix_libs)
+endif
AM_CFLAGS = $(DIX_CFLAGS) \
-DVENDOR_NAME=\""@VENDOR_NAME@"\" \
@@ -40,7 +46,11 @@ libdix_la_SOURCES = \
libxpstubs_la_SOURCES = \
xpstubs.c
-INCLUDES = -I$(top_srcdir)/Xprint
+if XPRINT
+libXpdix_la_SOURCES = $(libdix_la_SOURCES)
+libXpdix_la_CPPFLAGS = -I$(top_srcdir)/hw/xprint
+libXpdix_la_CFLAGS = $(AM_CFLAGS) $(XPRINT_CFLAGS)
+endif
EXTRA_DIST = buildatoms BuiltInAtoms CHANGES Xserver.d Xserver-dtrace.h.in