summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 22:19:51 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 22:19:51 +0000
commitd62943c040fd3d45079c9918c57f74f993b585d4 (patch)
treeb1f16ca4b6e1b664981e56fbef17efea8292f767 /configure.ac
parent0ee70f53ef9b05052ee079560df107d05a9c5407 (diff)
Set default font path to match the default in the monolith so fonts are
actually found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2102f69d6..634901443 100644
--- a/configure.ac
+++ b/configure.ac
@@ -312,9 +312,11 @@ AC_ARG_WITH(os-vendor, [ --with-os-vendor=OSVENDOR ],
AC_ARG_WITH(mesa-source, [ --with-mesa-source=MESA_SOURCE ],
[ MESA_SOURCE="$withval" ],
[ MESA_SOURCE="" ])
+FONTDIR="${libdir}/X11/fonts"
+DEFAULT_FONT_PATH="${FONTDIR}/misc/,${FONTDIR}/TTF/,${FONTDIR}/OTF,${FONTDIR}/Type1/,${FONTDIR}/CID/,${FONTDIR}/100dpi/,${FONTDIR}/75dpi/"
AC_ARG_WITH(default-font-path, [ --with-default-font-path=PATH ],
[ FONTPATH="$withval" ],
- [ FONTPATH="${datadir}/X11/fonts" ])
+ [ FONTPATH="${DEFAULT_FONT_PATH}" ])
AC_ARG_WITH(xkb-path, [ --with-xkb-path=PATH ],
[ XKBPATH="$withval" ],
[ XKBPATH="${datadir}/X11/xkb" ])