summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-12-02 06:02:45 +0000
committerKevin E Martin <kem@kem.org>2005-12-02 06:02:45 +0000
commit7c00afd0ec94e491f1a9ef32d6543ed51ea3319d (patch)
treeec85c667f59b7afcc9e263273552d4eba3e05632 /configure.ac
parent924518605b613eb66aa569877fa9f131e6f2a2fd (diff)
Define XFree86Server only where it is required.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 5abea6930..f2750e715 100644
--- a/configure.ac
+++ b/configure.ac
@@ -789,9 +789,10 @@ dnl ---------------------------------------------------------------------------
dnl DDX section.
dnl ---------------------------------------------------------------------------
-dnl These are used to define Xorg module and loader defines
+dnl These are used to define Xorg module, loader and general server defines
MODULE_DEFINES=""
LOADER_DEFINES=""
+SERVER_DEFINES=""
dnl DMX DDX
@@ -1078,8 +1079,9 @@ if test "x$XORG" = xyes; then
AC_SUBST([LD_EXPORT_SYMBOLS_FLAG])
dnl Module defines are used in the Xorg server and the drivers
- MODULE_DEFINES="-DIN_MODULE -DXFree86Module"
- LOADER_DEFINES="-DXFree86LOADER"
+ MODULE_DEFINES="$MODULE_DEFINES -DIN_MODULE -DXFree86Module"
+ LOADER_DEFINES="$LOADER_DEFINES -DXFree86LOADER"
+ SERVER_DEFINES="$SERVER_DEFINES -DXFree86Server"
dnl these only go in xorg-config.h
XF86CONFIGFILE="xorg.conf"
@@ -1131,9 +1133,6 @@ AM_CONDITIONAL(MFB, [test "x$XORG" = xyes])
AM_CONDITIONAL(CFB, [test "x$XORG" = xyes])
AM_CONDITIONAL(AFB, [test "x$XORG" = xyes])
-AC_SUBST([MODULE_DEFINES])
-AC_SUBST([LOADER_DEFINES])
-
dnl Xprint DDX
AC_MSG_CHECKING([whether to build Xprint DDX])
@@ -1315,6 +1314,10 @@ AM_CONDITIONAL(BUILD_KBD_MODE, [test x$BUILD_KBD_MODE = xyes])
AM_CONDITIONAL(BSD_KBD_MODE, [test x$KBD_MODE_TYPE = xbsd])
AM_CONDITIONAL(SUN_KBD_MODE, [test x$KBD_MODE_TYPE = xsun])
+AC_SUBST([MODULE_DEFINES])
+AC_SUBST([LOADER_DEFINES])
+AC_SUBST([SERVER_DEFINES])
+
CFLAGS="$XSERVER_CFLAGS $CFLAGS"
AC_SUBST([CFLAGS])