Age | Commit message (Collapse) | Author | Files | Lines |
|
One omission: gst_allocator_sysmem_get_type() was
exported but never in any public header file.
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=754464
|
|
gtk-doc can handle static inline functions just fine these days,
there's no need for this stuff any more.
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=739765
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=739765
|
|
* GstGlobalDeviceMonitor was renamed to GstDeviceMonitor
* Expand GST_MESSAGE_DEVICE to the full enum value names
* Correct the incorrect references to the GstDeviceProvider interfaces
* Describe caps arguments for gstcheck interface
* Add missing docs for GstNetAddressMeta and its add function
* Add docs for toc helper macros
* Avoid refering to GstValueList type as done elsewhere
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=732786
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=730957
|
|
This should help improve documentation generated for
languages other than C.
https://bugzilla.gnome.org/show_bug.cgi?id=730961
|
|
These are meant to specify features in caps that are required
for a specific structure, for example a specific memory type
or meta.
Semantically they could be though of as an extension of the media
type name of the structures and are handled exactly like that.
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=687520
|
|
|
|
Move the locking methods from GstMemory to GstMiniObject.
Add a miniobject flag to enable LOCKABLE objects. LOCKABLE objects can
use the lock/unlock API to control the access to the object.
Add a minobject flag that allows you to lock an object in readonly mode.
Modify the _is_writable() method to check the shared counter for LOCKABLE
objects. This allows us to control writability separately from the refcount for
LOCKABLE objects.
|
|
Remove gst_caps_union(), use gst_caps_merge(). This function was not used
anymore and it is unclear what the difference is with _merge().
|
|
Rename _do_simplify() to _simplify(). The name was introduced as a replacement
method for a deprecated method but we can now rename it again.
Fix some docs.
|
|
Make gst_caps_do_simplify() take ownership of the input caps and produce a
simplified output caps. This removes the requirement of having writable input
caps and the method can make the caps writable only when needed.
|
|
Rework some caps operations so they don't rely on writable caps but instead take
ownership of the input caps and do _make_writable() only when needed.
Remove some const from caps functions, it does not make much sense for
refcounted objects and does not allow us to return a refcount to the const input
caps.
Rework the base classes fixate vmethods to not operate on the caps in-place.
All this saves us around 30% of caps and structure copy and new operations.
|
|
into the implementation
|
|
...instead of using hackish subclass of GstCaps, which also
had some thread-safety problems.
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=666219
|
|
Rename the variable for GST_CAPS_NONE to _gst_caps_none for consistency and to
hie the fact that NONE caps are also accidentally empty caps.
|
|
Add a singleton for ANY and EMPTY caps and make the GST_CAPS_ANY and
GST_CAPS_NONE point to them. This makes the API more consistent now
that the macro does not magically create a ref. It also solves some leaks in
places where the macro was used to register a padtemplate.
|
|
Make some macros as inline functions for added type checking.
USe new gst_caps_take() in typefind
|
|
|
|
GST_STATIC_CAPS is missing initializer for GstMiniObject's n_weak_refs and
weak_refs resulting in compilation warning (llvm-gcc -Wall)
https://bugzilla.gnome.org/show_bug.cgi?id=664927
|
|
Conflicts:
gst/gstbuffer.h
gst/gstbufferlist.h
gst/gstcaps.h
gst/gstdatetime.h
gst/gstelementfactory.h
gst/gstevent.h
gst/gstghostpad.h
gst/gstindexfactory.h
gst/gstiterator.h
gst/gstmessage.h
gst/gstminiobject.h
gst/gstpipeline.h
gst/gstquery.h
gst/gstsegment.h
gst/gststructure.h
gst/gsttaglist.h
gst/gsturi.h
gst/gstvalue.h
libs/gst/base/gstbitreader.h
libs/gst/base/gstbytereader.h
libs/gst/base/gstbytewriter.h
Note: can't use G_GNUC_MALLOC with GstCaps return
values in 0.11 because of the EMPTY+ANY singletons.
|
|
Maybe gcc can do something clever with that, or at least
warn us if we don't save the return value somewhere.
|
|
Conflicts:
libs/gst/base/gstbasetransform.c
|
|
|
|
|
|
gst_caps_new_full()
If you get warnings, use gst_caps_new_empty().
https://bugzilla.gnome.org/show_bug.cgi?id=343346
|
|
|
|
Remove gst_mini_object_register() and add a GST_DEFINE_MINI_OBJECT macro to
define a _get_type() function for the boxed miniobject.
Remove a bunch of custom _get_type() functions and replace them with the
miniobject macro.
Rename some _init method to _priv_*_initialize() like the rest of them.
Inspired by patch from Johan Dahlin and see bug #657603
|
|
Use them to fix warnings when building with ICC.
API: GST_CAPS_FLAGS_NONE
https://bugzilla.gnome.org/show_bug.cgi?id=656265
|
|
Add a fixate function and use it in gstpad.c
|
|
Make the Array of structures private. This should allow us to implement
the array more efficiently or with some preallocated structures when
we want to later.
Add a new method to clean up a static structure so that we can remove some code
that pokes into the private bits of the caps.
|
|
Remove some custom made refcounting methods and use the miniobject ones instead.
|
|
|
|
API: gst_caps_is_subset_structure()
This allows to check if a structure is a subset of given
caps without allocating a new caps instance for it.
|
|
|
|
Conflicts:
docs/gst/gstreamer-sections.txt
gst/gstelementfactory.c
gst/gstminiobject.c
|
|
|
|
Conflicts:
gst/gst.c
libs/gst/base/gstcollectpads.c
|
|
Just like gst_caps_intersect, but adds a new parameter 'mode'
that allows selecting the intersection algorithm to use.
Currently we have GST_CAPS_INTERSECT_MODE_ZIG_ZAG (default) and
GST_CAPS_INTERSECT_MODE_FIRST.
API: gst_caps_intersect_full
API: GstCapsIntersectMode
API: GST_CAPS_INTERSECT_MODE_ZIG_ZAG
API: GST_CAPS_INTERSECT_MODE_FIRST
https://bugzilla.gnome.org/show_bug.cgi?id=617045
|
|
|
|
|
|
|
|
More minionject stuff.
|
|
|
|
More work on making miniobject a simple allocated struct.
|
|
First attempt at making miniobject a simple boxed type.
|