summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index f15fe4d05..035ba3cd0 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,6 +1,8 @@
# FIXME: make check work on windows
-if host_machine.system() != 'windows'
- subdir('check')
+if host_system != 'windows'
+ if not get_option('tests').disabled() and gstcheck_dep.found()
+ subdir('check')
+ endif
endif
if not get_option('examples').disabled()
subdir('examples')