summaryrefslogtreecommitdiff
path: root/gst-libs/gst/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/Makefile.am')
-rw-r--r--gst-libs/gst/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/gst-libs/gst/Makefile.am b/gst-libs/gst/Makefile.am
index db67fc89f..79fa13463 100644
--- a/gst-libs/gst/Makefile.am
+++ b/gst-libs/gst/Makefile.am
@@ -6,9 +6,13 @@ if USE_OPENCV
OPENCV_DIR=opencv
endif
+if USE_SCTP
+SCTP_DIR=sctp
+endif
+
SUBDIRS = uridownloader adaptivedemux interfaces basecamerabinsrc codecparsers \
insertbin mpegts video audio player isoff webrtc $(WAYLAND_DIR) \
- $(OPENCV_DIR)
+ $(OPENCV_DIR) $(SCTP_DIR)
noinst_HEADERS = gst-i18n-plugin.h gettext.h glib-compat-private.h
DIST_SUBDIRS = uridownloader adaptivedemux interfaces basecamerabinsrc \
@@ -18,7 +22,7 @@ adaptivedemux: uridownloader
INDEPENDENT_SUBDIRS = \
interfaces basecamerabinsrc codecparsers insertbin uridownloader \
- mpegts player isoff $(WAYLAND_DIR) $(OPENCV_DIR)
+ mpegts player isoff $(WAYLAND_DIR) $(OPENCV_DIR) $(SCTP_DIR)
.PHONY: independent-subdirs $(INDEPENDENT_SUBDIRS)