summaryrefslogtreecommitdiff
path: root/ext/srt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/srt/Makefile.am')
-rw-r--r--ext/srt/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/ext/srt/Makefile.am b/ext/srt/Makefile.am
new file mode 100644
index 000000000..02e0d110a
--- /dev/null
+++ b/ext/srt/Makefile.am
@@ -0,0 +1,40 @@
+plugin_LTLIBRARIES = libgstsrt.la
+
+libgstsrt_la_SOURCES = \
+ gstsrt.c \
+ gstsrtbasesrc.c \
+ gstsrtclientsrc.c \
+ gstsrtserversrc.c \
+ gstsrtbasesink.c \
+ gstsrtclientsink.c \
+ gstsrtserversink.c \
+ $(NULL)
+
+libgstsrt_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ $(GIO_CFLAGS) \
+ $(SRT_CFLAGS) \
+ $(NULL)
+
+libgstsrt_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) \
+ $(GST_LIBS) \
+ $(GIO_LIBS) \
+ -lgstbase-1.0 \
+ $(SRT_LIBS) \
+ $(NULL)
+
+libgstsrt_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+noinst_HEADERS = \
+ gstsrtbasesink.h \
+ gstsrtclientsink.h \
+ gstsrtserversrc.h \
+ gstsrtbasesrc.h \
+ gstsrtclientsrc.h \
+ gstsrtserversink.h
+
+include $(top_srcdir)/common/gst-glib-gen.mak