summaryrefslogtreecommitdiff
path: root/ext/sctp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/sctp/Makefile.am')
-rw-r--r--ext/sctp/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/ext/sctp/Makefile.am b/ext/sctp/Makefile.am
new file mode 100644
index 000000000..7f535ee69
--- /dev/null
+++ b/ext/sctp/Makefile.am
@@ -0,0 +1,21 @@
+plugin_LTLIBRARIES = libgstsctp.la
+
+libgstsctp_la_SOURCES = \
+ gstsctpplugin.c \
+ sctpassociation.c \
+ gstsctpenc.c \
+ gstsctpdec.c
+
+libgstsctp_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ $(USRSCTP_CFLAGS) \
+ -I$(top_srcdir)/gst-libs
+
+libgstsctp_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(USRSCTP_LIBS) $(top_builddir)/gst-libs/gst/sctp/libgstsctp-1.0.la
+
+noinst_HEADERS = \
+ sctpassociation.h \
+ gstsctpenc.h \
+ gstsctpdec.h