summaryrefslogtreecommitdiff
path: root/gst-libs/gst/interfaces/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-08-31 14:37:46 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-08-31 14:41:00 +0530
commitcea5e3fcdb96deabd6cf6f7688de986a2512fdc3 (patch)
tree59ef5c0ea9aec770987dd6f9cbe79da4d99cfb0f /gst-libs/gst/interfaces/meson.build
parent515e2d765a63b60c3811efc7654b55df028c878a (diff)
meson: Maintain macOS ABI through dylib versioning
Requires Meson 0.48, but the feature will be ignored on older versions so it's safe to add it without bumping the requirement. Documentation: https://github.com/mesonbuild/meson/blob/master/docs/markdown/Reference-manual.md#shared_library
Diffstat (limited to 'gst-libs/gst/interfaces/meson.build')
-rw-r--r--gst-libs/gst/interfaces/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/gst-libs/gst/interfaces/meson.build b/gst-libs/gst/interfaces/meson.build
index 31c18c885..4e2fb4305 100644
--- a/gst-libs/gst/interfaces/meson.build
+++ b/gst-libs/gst/interfaces/meson.build
@@ -18,6 +18,7 @@ gstphotography = library('gstphotography-' + api_version,
include_directories : [configinc, libsinc],
version : libversion,
soversion : soversion,
+ darwin_versions : osxversion,
install : true,
dependencies : [gst_dep],
)