summaryrefslogtreecommitdiff
path: root/gst-libs/gst/audio/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2016-08-12 21:21:45 +0530
committerTim-Philipp Müller <tim@centricular.com>2016-08-20 11:35:54 +0100
commit42af2d66d8e4aa73c38be07c8460397adf21ce30 (patch)
tree59b54f11f5aacc7ca331b913a6e2c30260865873 /gst-libs/gst/audio/meson.build
parent7e2b68fe2f22b4f12d876aa9385f594244a631b8 (diff)
Add support for Meson as alternative/parallel build system
https://github.com/mesonbuild/meson With contributions from: Tim-Philipp Müller <tim@centricular.com> Matej Knopp <matej.knopp@gmail.com> Jussi Pakkanen <jpakkane@gmail.com> (original port) Highlights of the features provided are: * Faster builds on Linux (~40-50% faster) * The ability to build with MSVC on Windows * Generate Visual Studio project files * Generate XCode project files * Much faster builds on Windows (on-par with Linux) * Seriously fast configure and building on embedded ... and many more. For more details see: http://blog.nirbheek.in/2016/05/gstreamer-and-meson-new-hope.html http://blog.nirbheek.in/2016/07/building-and-developing-gstreamer-using.html Building with Meson should work on both Linux and Windows, but may need a few more tweaks on other operating systems.
Diffstat (limited to 'gst-libs/gst/audio/meson.build')
-rw-r--r--gst-libs/gst/audio/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/gst-libs/gst/audio/meson.build b/gst-libs/gst/audio/meson.build
new file mode 100644
index 000000000..e04c2a10f
--- /dev/null
+++ b/gst-libs/gst/audio/meson.build
@@ -0,0 +1,19 @@
+badaudio_sources = ['gstaudioaggregator.c']
+badaudio_headers = ['gstaudioaggregator.h']
+install_headers(badaudio_headers, subdir : 'gstreamer-1.0/gst/audio')
+
+
+gstbadaudio = library('gstbadaudio-' + api_version,
+ badaudio_sources,
+ c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API'],
+ include_directories : [configinc, libsinc],
+ version : libversion,
+ soversion : soversion,
+ install : true,
+ dependencies : [gstbadbase_dep, gstaudio_dep],
+ vs_module_defs: vs_module_defs_dir + 'libgstbadaudio.def',
+)
+
+gstbadaudio_dep = declare_dependency(link_with : gstbadaudio,
+ include_directories : [libsinc],
+ dependencies : [gstbadbase_dep, gstaudio_dep])