summaryrefslogtreecommitdiff
path: root/ext/smoothstreaming/Makefile.am
diff options
context:
space:
mode:
authorThiago Santos <thiago.sousa.santos@collabora.com>2012-11-08 15:42:39 -0300
committerThiago Santos <thiago.sousa.santos@collabora.com>2013-05-07 20:02:41 -0300
commitef25e05b7cd6be35f9473545e22d15ef44591c1f (patch)
tree4daf914d1257529c79e5c35ac2edcae7ddf37b0a /ext/smoothstreaming/Makefile.am
parentf0211e5b7b55d607086bbdb7458981f9a551c661 (diff)
smoothstreaming: build directory stubs for new plugin
Initial build structure for MS' Smooth Streaming plugin Conflicts: ext/Makefile.am
Diffstat (limited to 'ext/smoothstreaming/Makefile.am')
-rw-r--r--ext/smoothstreaming/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/ext/smoothstreaming/Makefile.am b/ext/smoothstreaming/Makefile.am
new file mode 100644
index 000000000..935508a0b
--- /dev/null
+++ b/ext/smoothstreaming/Makefile.am
@@ -0,0 +1,28 @@
+
+plugin_LTLIBRARIES = libgstsmoothstreaming.la
+
+libgstsmoothstreaming_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS)
+libgstsmoothstreaming_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgsttag-@GST_MAJORMINOR@ \
+ $(GST_BASE_LIBS) $(GST_LIBS) $(ZLIB_LIBS)
+libgstsmoothstreaming_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
+libgstsmoothstreaming_la_SOURCES = gstsmoothstreaming-plugin.c
+libgstsmoothstreaming_la_LIBTOOLFLAGS = --tag=disable-static
+
+#noinst_HEADERS =
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+ androgenizer \
+ -:PROJECT libgstsmoothstreaming -:SHARED libgstsmoothstreaming \
+ -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libgstsmoothstreaming_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(CPPFLAGS) $(libgstsmoothstreaming_la_CFLAGS) \
+ -:LDFLAGS $(libgstsmoothstreaming_la_LDFLAGS) \
+ $(libgstsmoothstreaming_la_LIBADD) \
+ -ldl \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
+ > $@
+