summaryrefslogtreecommitdiff
path: root/eog/Makefile.am
diff options
context:
space:
mode:
authorMichal Hruby <michal.mhr@gmail.com>2010-06-07 21:50:44 +0200
committerMichal Hruby <michal.mhr@gmail.com>2010-06-07 21:50:44 +0200
commitf26aeb626bf8a92dd70433837caab4b69797ffa1 (patch)
tree0180dcb4e2c7ecfff1958df994fabaf93c265f54 /eog/Makefile.am
parent918c2532a5d462a37d9b041558246ff77130989b (diff)
Use autotools for most plugins (FF still missing)
Diffstat (limited to 'eog/Makefile.am')
-rw-r--r--eog/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/eog/Makefile.am b/eog/Makefile.am
new file mode 100644
index 0000000..823a030
--- /dev/null
+++ b/eog/Makefile.am
@@ -0,0 +1,19 @@
+PLUGIN_FILES = zeitgeist.eog-plugin zeitgeist_plugin.py
+
+eogplugindir = $(libdir)/eog/plugins
+eogplugin_DATA = $(PLUGIN_FILES)
+
+# we want to allow also local install
+EOG_PLUGIN_HOME_DIR = ~/.gnome2/eog/plugins
+
+local-install:
+ mkdir -p $(EOG_PLUGIN_HOME_DIR)
+ cp $(PLUGIN_FILES) $(EOG_PLUGIN_HOME_DIR)
+
+local-uninstall:
+ for f in $(PLUGIN_FILES); \
+ do \
+ echo remove $$f; \
+ rm -f $(EOG_PLUGIN_HOME_DIR)/$$f; \
+ done
+