summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorten Mjelva <morten.mjelva@gmail.com>2010-12-05 11:15:39 +0100
committerMorten Mjelva <morten.mjelva@gmail.com>2010-12-05 11:15:39 +0100
commitcc701e4dafc3e804fa1926ac6d6950e22eb596f9 (patch)
tree9bdcc51dd250ed1115ec226324017183d3e38c0d /configure.ac
parentcef7d3c15bb9fcf00c93f119e17d07697d773a52 (diff)
Adds the telepathy plugin to the build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d4a3bba..b4fa4e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,7 +65,7 @@ AC_ARG_ENABLE([all-plugins],
AC_MSG_RESULT($all_plugins)
# The full list of plugins
-allowed_plugins="bzr chrome eog firefox-libzg geany gedit rhythmbox totem-libzg vim emacs tomboy"
+allowed_plugins="bzr chrome eog firefox-libzg geany gedit rhythmbox totem-libzg vim emacs tomboy telepathy"
# currently disabled = "epiphany"
# npapi-plugin has a template Makefile.am, but don't use it directly
@@ -222,6 +222,8 @@ for plugin in ${used_plugins}; do
emacs)
AM_PATH_LISPDIR
;;
+ telepathy)
+ ;;
*)
plugin_error_or_ignore "${plugin} is not handled"
continue
@@ -307,6 +309,10 @@ if test "x${PLUGINS}" != "x" ; then
AC_CONFIG_FILES([emacs/Makefile])
continue 2
;;
+ telepathy)
+ AC_CONFIG_FILES([telepathy/Makefile])
+ continue 2
+ ;;
*)
AC_MSG_ERROR([cannot configure ${allowed_plugin}])
continue 2