summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Hruby <michal.mhr@gmail.com>2010-06-08 19:50:08 +0200
committerMichal Hruby <michal.mhr@gmail.com>2010-06-08 19:50:08 +0200
commitbb5ede9b73a7473c8f87779165d6b79c2748a446 (patch)
tree6dae488d818db7386e3d545a5a20b6863dca7f86 /configure.ac
parentbf44fa74f7451f9f6539a6fea7f3729667aac662 (diff)
Add new rhythmbox plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bfbea94..8c828f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,7 +51,7 @@ AC_ARG_ENABLE([all-plugins],
AC_MSG_RESULT($all_plugins)
# The full list of plugins
-allowed_plugins="bzr chrome eog firefox-libzg geany gedit rhythmbox totem-libzg"
+allowed_plugins="bzr chrome eog firefox-libzg geany gedit rhythmbox rhythmbox-libzg totem-libzg"
# currently disabled = "epiphany tomboy"
# npapi-plugin has a template Makefile.am, but don't use it directly
@@ -131,6 +131,20 @@ for plugin in ${used_plugins}; do
;;
rhythmbox)
;;
+ rhythmbox-libzg)
+ if test "${with_vala}" != "yes" ; then
+ plugin_error_or_ignore "you need vala installed to use the ${plugin} plugin"
+ continue
+ fi
+ if test "${HAVE_LIBZG}" != "yes" ; then
+ plugin_error_or_ignore "libzeitgeist not found"
+ continue
+ fi
+ if test "${HAVE_GTK}" != "yes" ; then
+ plugin_error_or_ignore "gtk+-2.0 not found"
+ continue
+ fi
+ ;;
tomboy)
# not supported atm
continue
@@ -189,6 +203,7 @@ firefox-libzg/extension/components/Makefile
geany/Makefile
gedit/Makefile
rhythmbox/Makefile
+rhythmbox-libzg/Makefile
totem-libzg/Makefile
])