summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Hruby <michal.mhr@gmail.com>2010-06-08 02:24:42 +0200
committerMichal Hruby <michal.mhr@gmail.com>2010-06-08 02:24:42 +0200
commit4ab47eb902c77717cdafaa976df0f7c66f094627 (patch)
treea80f84d9d6a5083fdc9f57dbb0b32aa9a3c61541 /configure.ac
parentdaecca2eb80a1b3e7d41684b169a1854edd8de2e (diff)
Make also firefox use automake
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5610c27..bfbea94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,6 +2,8 @@ AC_INIT([zeitgeist-dataproviders],
[0.1.0],
[https://bugs.launchpad.net/zeitgeist-dataproviders/])
+AC_PREFIX_DEFAULT([/usr])
+
AM_INIT_AUTOMAKE([1.9 foreign])
# Enable silent build when available (Automake 1.11)
@@ -49,8 +51,8 @@ AC_ARG_ENABLE([all-plugins],
AC_MSG_RESULT($all_plugins)
# The full list of plugins
-allowed_plugins="bzr chrome eog geany gedit rhythmbox totem-libzg"
-# currently disabled = "epiphany firefox-libzg tomboy"
+allowed_plugins="bzr chrome eog firefox-libzg geany gedit rhythmbox totem-libzg"
+# currently disabled = "epiphany tomboy"
# npapi-plugin has a template Makefile.am, but don't use it directly
# - see chrome's Makefile.am for how to compile it
@@ -96,6 +98,16 @@ for plugin in ${used_plugins}; do
plugin_error_or_ignore "libzeitgeist not found"
continue
fi
+ PKG_CHECK_MODULES(LIBXUL, libxul,
+ [HAVE_LIBXUL=yes], [HAVE_LIBXUL=no])
+ if test "${HAVE_LIBXUL}" != "yes" ; then
+ plugin_error_or_ignore "libxul not found"
+ continue
+ fi
+ XPIDL_BIN="`$PKG_CONFIG --variable=sdkdir libxul`/bin/xpidl"
+ AC_SUBST(XPIDL_BIN)
+ XUL_IDLDIR="`$PKG_CONFIG --variable=idldir libxul`"
+ AC_SUBST(XUL_IDLDIR)
;;
geany)
if test "${HAVE_LIBZG}" != "yes" ; then
@@ -171,6 +183,9 @@ Makefile
bzr/Makefile
chrome/Makefile
eog/Makefile
+firefox-libzg/Makefile
+firefox-libzg/extension/Makefile
+firefox-libzg/extension/components/Makefile
geany/Makefile
gedit/Makefile
rhythmbox/Makefile