summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorManish Sinha <manishsinha@ubuntu.com>2011-05-02 23:58:16 +0530
committerManish Sinha <manishsinha@ubuntu.com>2011-05-02 23:58:16 +0530
commit3e1699e6f945d419c0fb74705749319b9b4910f9 (patch)
tree9e546f7f511e441239a13a0cae12090f0243c8a4 /configure.ac
parent5a9bf259faa42ad30456f8a1933771d959842819 (diff)
Fixes bug no #709103 in which the dataprovider does not work with Firefox 4 (XUL Runner 2.0)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8f9bd33..9b50beb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,8 +65,8 @@ AC_ARG_ENABLE([all-plugins],
AC_MSG_NOTICE([Requested to enable all plugins: ${all_plugins}])
# The full list of plugins
-allowed_plugins="bzr chrome eog geany vim emacs tomboy telepathy xchat"
-# currently disabled = "epiphany firefox-libzg "
+allowed_plugins="bzr chrome eog geany vim emacs tomboy telepathy xchat firefox-libzg"
+# currently disabled = "epiphany"
# npapi-plugin has a template Makefile.am, but don't use it directly
# - see chrome's Makefile.am for how to compile it
@@ -112,17 +112,17 @@ for plugin in ${used_plugins}; do
plugin_error_or_ignore "libzeitgeist not found"
continue
fi
- PKG_CHECK_MODULES(LIBXUL, libxul,
+ PKG_CHECK_MODULES(LIBXUL_2_0, libxul >= 2.0,
[HAVE_LIBXUL=yes], [HAVE_LIBXUL=no])
if test "${HAVE_LIBXUL}" != "yes" ; then
- plugin_error_or_ignore "libxul not found"
+ plugin_error_or_ignore "libxul 2.0+ not found"
continue
fi
XPIDL_BIN="`$PKG_CONFIG --variable=sdkdir libxul`/bin/xpidl"
AC_SUBST(XPIDL_BIN)
XUL_IDLDIR="`$PKG_CONFIG --variable=idldir libxul`"
AC_SUBST(XUL_IDLDIR)
- AC_DEFINE(MOZ_NO_MOZALLOC, ["For Mozilla Firefox 4"])
+ AC_DEFINE(MOZ_NO_MOZALLOC, ["For Mozilla Firefox 4"])
;;
geany)
if test "${HAVE_LIBZG}" != "yes" ; then