summaryrefslogtreecommitdiff
path: root/salut/Makefile.am
diff options
context:
space:
mode:
authorAlvaro Soliverez <alvaro.soliverez@collabora.co.uk>2011-12-13 16:37:54 -0300
committerAlvaro Soliverez <alvaro.soliverez@collabora.co.uk>2012-02-22 10:37:40 -0300
commit9ceff79bbfa423452249298684543f5f2dbe581b (patch)
tree79791da6ffcb7f9801d60bae5d78bd6aec7e5604 /salut/Makefile.am
parent1e8ce5770f6a908b133aa2b0401b2e4f7dc9c1b5 (diff)
Support for building on Android, modified from patches by Derek Foreman and Johnny Lamb
Diffstat (limited to 'salut/Makefile.am')
-rw-r--r--salut/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/salut/Makefile.am b/salut/Makefile.am
index 20ea5ac..8ec5fa0 100644
--- a/salut/Makefile.am
+++ b/salut/Makefile.am
@@ -3,7 +3,8 @@ AM_CFLAGS = \
-DSALUT \
-I$(top_srcdir)/plugin-base \
$(SALUT_CFLAGS) \
- $(TELEPATHY_YTSTENUT_CFLAGS)
+ $(TELEPATHY_YTSTENUT_CFLAGS) \
+ $(WOCKY_CFLAGS)
plugindir = $(salutplugindir)
@@ -12,8 +13,8 @@ plugin_LTLIBRARIES = ytstenut-salut.la
AM_LDFLAGS = -module -avoid-version -shared
ytstenut_salut_la_LIBADD = \
- $(SALUT_LIBS) \
- $(TELEPATHY_YTSTENUT_LIBS)
+ $(TELEPATHY_YTSTENUT_LIBS) \
+ $(WOCKY_LIBS)
ytstenut_salut_la_SOURCES = \
$(top_srcdir)/plugin-base/ytstenut.c \
@@ -28,3 +29,14 @@ ytstenut_salut_la_SOURCES = \
$(top_srcdir)/plugin-base/channel-manager.h \
$(top_srcdir)/plugin-base/utils.c \
$(top_srcdir)/plugin-base/utils.h
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+ androgenizer -:PROJECT ytstenut-plugins \
+ -:SHARED ytstenut-salut -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(ytstenut_salut_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(CFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CFLAGS) -I../../wocky \
+ -:CPPFLAGS $(CPPFLAGS) $(AM_CPPFLAGS) -DSALUT \
+ -:LDFLAGS $(AM_LDFLAGS) $(ytstenut_salut_la_LIBADD) -ltelepathy-salut \
+ > $@