summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLyude Paul <lyude@redhat.com>2017-10-23 16:21:19 -0400
committerAdam Jackson <ajax@redhat.com>2017-10-24 10:53:56 -0400
commit4d53e30651c0fe5f7be38ae8529fa49846d39549 (patch)
tree503d9533bbfc4beeedec3875a1951465bde38c85 /meson.build
parent5893e72a20ffa5cfcd6d0c7c5c934b92546d76c3 (diff)
meson: Don't use '' in link_with, ever
String arguments as elements in the array passed to the link_with argument in meson's executable() functions are not valid and will end up causing the build file generation to file. This actually ended up exposing a bug in meson that caused it not to report where in the meson.build file it was failing: https://github.com/mesonbuild/meson/pull/2527 The proper way to have a variable that can contain either an empty link target or an actual link target is: some_target = [] if some_cond some_target = static_library(...) endif This way if some_cond is False, some_target gets set to [], gets passed to executable() in the link_with array, and then gets removed by array flattening. This also unbreaks Xwayland builds with -Dglx=false, the thing that originally made me notice this. Signed-off-by: Lyude Paul <lyude@redhat.com> Reviewed-by: Jon Turney <jon.turney@dronecode.org.uk>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 2b63f0f19..6e7fc0664 100644
--- a/meson.build
+++ b/meson.build
@@ -214,7 +214,7 @@ if int10 == 'auto'
endif
endif
-hal_dep = ''
+hal_dep = []
if hal_option == 'auto'
if not build_udev
hal_dep = dependency('hal', required: false)
@@ -264,7 +264,7 @@ endif
# XXX: Add more sha1 options, because Linux is about choice
sha1_dep = nettle_dep
-xdmcp_dep = ''
+xdmcp_dep = []
if get_option('xdmcp')
xdmcp_dep = dependency('xdmcp')
endif