summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Carlier <lordheavym@gmail.com>2018-03-01 12:58:16 +0100
committerAdam Jackson <ajax@redhat.com>2018-03-02 12:05:49 -0500
commit43ffd572592d26bb78decfdf55e643bdfb011d3f (patch)
treeaf63b9b394be77cfb4bfdef64c50b5fa481e41cc /meson.build
parentde4565727a0bb199365d33e3c98d9ddd3e0de6f2 (diff)
meson: Make SHM extension optional
v2: check for header 'sys/shm.h' Signed-off-by: Laurent Carlier <lordheavym@gmail.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8e17c4f82..c66a2501c 100644
--- a/meson.build
+++ b/meson.build
@@ -387,8 +387,14 @@ if (get_option('linux_acpi') == true and
endif
endif
+build_mitshm = false
+if get_option('mitshm') == 'auto'
+ build_mitshm = cc.has_header('sys/shm.h')
+elif get_option('mitshm') == 'true'
+ build_mitshm = true
+endif
+
# XXX: Allow configuration of these.
-build_mitshm = true
build_xselinux = false
build_xf86vidmode = xf86vidmodeproto_dep.found()