summaryrefslogtreecommitdiff
path: root/hw/vfb/man/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-01-09 20:28:29 -0500
committerKeith Packard <keithp@keithp.com>2011-01-18 15:11:10 -0800
commit885a3330092c13786baa3aaabd728e71962486c4 (patch)
tree3e90e679ff48294c5861255a8c49036b96d1eacc /hw/vfb/man/Makefile.am
parentc86f7c2b8eedd3126066a3aff44bc8767eb5e277 (diff)
man: refactor common code in the man pages makefiles
Create a manpages.am makefile snippet in the root dir. Each man page makefile includes manpages.am. Now all man pages in xserver are generated the same way using the same method as all of other xorg modules. All ".man.pre" files in git are ".man" now. Links are no longer created between different file types. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: RĂ©mi Cardona <remi@gentoo.org> Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'hw/vfb/man/Makefile.am')
-rw-r--r--hw/vfb/man/Makefile.am10
1 files changed, 1 insertions, 9 deletions
diff --git a/hw/vfb/man/Makefile.am b/hw/vfb/man/Makefile.am
index 5decaddb1..93941882a 100644
--- a/hw/vfb/man/Makefile.am
+++ b/hw/vfb/man/Makefile.am
@@ -1,10 +1,2 @@
-appmandir = $(APP_MAN_DIR)
+include $(top_srcdir)/manpages.am
appman_PRE = Xvfb.man
-appman_DATA = $(appman_PRE:man=$(APP_MAN_SUFFIX))
-
-EXTRA_DIST = $(appman_PRE)
-CLEANFILES = $(appman_DATA)
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@