summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-01-08 17:36:07 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-01-08 17:36:28 -0800
commit88740c4855babedbea420b5e1b35ae105d1f1026 (patch)
treefd7745185daa58f162471d7cb9badb66571e3d58 /configure.ac
parent282a4dcaabc5f0cd6f7d3819aa648333b93b265e (diff)
Use PKG_CHECK_EXISTS(libdrm) to determine if DRI should be enabled on Solaris
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c4aafaa11..3b97e0478 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,6 +353,9 @@ case $host_os in
DRI=yes
KDRIVE_HW=yes
;;
+ *solaris*)
+ PKG_CHECK_EXISTS(libdrm, DRI=yes, DRI=no)
+ ;;
esac
AM_CONDITIONAL(KDRIVE_HW, test "x$KDRIVE_HW" = xyes)
@@ -363,6 +366,8 @@ if test "x$use_x86_asm" = xyes && test "x$GCC" = xyes ; then
#error Not supported
#endif
], mmx_capable=yes, mmx_capable=no)
+else
+ mmx_capable=no
fi
AC_MSG_RESULT([$mmx_capable])
AM_CONDITIONAL(MMX_CAPABLE, [test "x$mmx_capable" = xyes])