summaryrefslogtreecommitdiff
path: root/hw/xwin/Makefile.am
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2012-09-04 17:28:16 +0100
committerJon TURNEY <jon.turney@dronecode.org.uk>2012-11-05 11:14:21 +0000
commit5bc4c53d23d02d3d7297a8f00a92b6e4d5e0d6fe (patch)
tree18d04466dcaf54ce89fccfeb9ba0e26a07eb9cac /hw/xwin/Makefile.am
parent53830281b4da096f9c13107d73ec9c76ff1d14cc (diff)
hw/xwin: Link with libdxguid rather than defining the DirectX GUIDs ourselves
Decruftify by linking with libdxguid rather than defining the DirectX GUIDs ourselves. This fixes compilation with MinGW-w64 w32api headers, which do not provide GUID_SECT (which only ever did anything for gcc prior to 2.95, anyhow) Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk> Reviewed-by: Colin Harrison <colin.harrison@virgin.net>
Diffstat (limited to 'hw/xwin/Makefile.am')
-rw-r--r--hw/xwin/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/hw/xwin/Makefile.am b/hw/xwin/Makefile.am
index 99dc55631..3fcaf9d0b 100644
--- a/hw/xwin/Makefile.am
+++ b/hw/xwin/Makefile.am
@@ -147,6 +147,8 @@ XWin_SOURCES = $(SRCS)
INCLUDES = -I$(top_srcdir)/miext/rootless
+XWIN_SYS_LIBS += -ldxguid
+
XWin_DEPENDENCIES = $(MULTIWINDOWEXTWM_LIBS) $(XWIN_GLX_LIBS) $(XWIN_LIBS) $(MAIN_LIB) $(XSERVER_LIBS)
XWin_LDADD = $(MULTIWINDOWEXTWM_LIBS) $(XWIN_GLX_LIBS) $(XWIN_GLX_LINK_FLAGS) $(XWIN_LIBS) $(MAIN_LIB) $(XSERVER_LIBS) $(XSERVER_SYS_LIBS) $(XWIN_SYS_LIBS)
XWin_LDFLAGS = -mwindows -static