summaryrefslogtreecommitdiff
path: root/hw/xfree86/dixmods/Makefile.am
diff options
context:
space:
mode:
authorTomas Carnecky <tom@dbservice.com>2012-07-10 02:03:02 +0100
committerKeith Packard <keithp@keithp.com>2012-07-09 23:28:36 -0700
commitb8c9ab0fea0be299d9f48ac0c4ed0474104a7556 (patch)
treeb74ada85deed0b049c0ef52277dbc818e25431e7 /hw/xfree86/dixmods/Makefile.am
parentbf61bf69b2b4f9e9993ca771de100079c7696bea (diff)
Move RECORD from external module to built-in
Rather than languishing in its own special module, move RECORD into the core server. Signed-off-by: Tomas Carnecky <tom@dbservice.com> Reviewed-by: Daniel Stone <daniel@fooishbar.org> Reviewed-by: Jamey Sharp <jamey@minilop.net> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'hw/xfree86/dixmods/Makefile.am')
-rw-r--r--hw/xfree86/dixmods/Makefile.am11
1 files changed, 1 insertions, 10 deletions
diff --git a/hw/xfree86/dixmods/Makefile.am b/hw/xfree86/dixmods/Makefile.am
index 827b952b5..3aa7d27c5 100644
--- a/hw/xfree86/dixmods/Makefile.am
+++ b/hw/xfree86/dixmods/Makefile.am
@@ -6,17 +6,12 @@ if GLX
GLXMODS = libglx.la
endif
-if RECORD
-RECORDMOD = librecord.la
-endif
-
module_LTLIBRARIES = libfb.la \
libwfb.la \
libshadow.la
extsmoduledir = $(moduledir)/extensions
-extsmodule_LTLIBRARIES = $(RECORDMOD) \
- $(GLXMODS)
+extsmodule_LTLIBRARIES = $(GLXMODS)
AM_CFLAGS = @XORG_CFLAGS@ @DIX_CFLAGS@
INCLUDES = @XORG_INCS@ \
@@ -44,10 +39,6 @@ endif
endif
libglx_la_SOURCES = glxmodule.c
-librecord_la_LDFLAGS = -module -avoid-version $(LD_NO_UNDEFINED_FLAG)
-librecord_la_LIBADD = $(top_builddir)/record/librecord.la
-librecord_la_SOURCES = recordmod.c
-
libshadow_la_LDFLAGS = -module -avoid-version $(LD_NO_UNDEFINED_FLAG)
libshadow_la_LIBADD = $(top_builddir)/miext/shadow/libshadow.la
if NO_UNDEFINED