summaryrefslogtreecommitdiff
path: root/exa/Makefile.am
diff options
context:
space:
mode:
authorMaarten Maathuis <madman2003@gmail.com>2009-07-22 21:35:41 +0200
committerMaarten Maathuis <madman2003@gmail.com>2009-08-06 23:48:13 +0200
commitac7ac913fd98ea359c05c89968ab53a3223615b4 (patch)
tree084201c6a72c02db79556508b5ff9af7166ecdc1 /exa/Makefile.am
parent3abbd327f4a732408119de1f8e9ecba4812772a5 (diff)
exa: Split out some classic and driver allocated pixmap code into seperate files
- Create a few seperate functions and a few private function pointers. - Replace a few if conditions with a check for pExaPix->pDamage instead. - This is in preperation of a third scheme that lies somewhere in between. - Code clarity would have suffered (i started working on it and didn't like the mess).
Diffstat (limited to 'exa/Makefile.am')
-rw-r--r--exa/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/exa/Makefile.am b/exa/Makefile.am
index 2b3f1e416..bf2c138d8 100644
--- a/exa/Makefile.am
+++ b/exa/Makefile.am
@@ -17,11 +17,12 @@ AM_CFLAGS = $(XORG_CFLAGS) $(DIX_CFLAGS)
libexa_la_SOURCES = \
exa.c \
exa.h \
+ exa_classic.c \
+ exa_migration.c \
+ exa_driver.c \
exa_accel.c \
exa_glyphs.c \
- exa_migration.c \
exa_offscreen.c \
exa_render.c \
exa_priv.h \
exa_unaccel.c
-