summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJurij Smakov <jurij@wooyd.org>2007-12-28 23:59:53 +0200
committerDaniel Stone <daniel@fooishbar.org>2007-12-29 00:00:04 +0200
commit36ff05771b0699aa80ad718e24097bc25cb4fb00 (patch)
treeb37661db94e2613029d644beca06c04aa5d3e5a1 /configure.ac
parentbae459cfc4f17a5ec5f2810e9f913e3ad2d8b8d4 (diff)
GL: Add GLX compile flags lost in modular X server changes
RISC chips that trap on unaligned loads and stores need to define __GLX_ALIGN64. This used to get added to the cflags in the old *.cf files but it no longer does in the modular X server. Also, Alpha needs to pass -mieee to the compiler as well. This is a simple backport of a patch that debian, and probably other distributions, have been applying forever. To the best of my knowledge the patch was written by Jurij Smakov. See Debian bug number #388125. I just checked and this has been rotting for more than a year in freedesktop bugzilla as #8392. Signed-off-by: David S. Miller <davem@davemloft.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b718c9f5..0742040c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,6 +304,7 @@ case $host_cpu in
*freebsd*) SYS_LIBS=-lio ;;
*netbsd*) AC_DEFINE(USE_ALPHA_PIO, 1, [NetBSD PIO alpha IO]) ;;
esac
+ GLX_ARCH_DEFINES="-D__GLX_ALIGN64 -mieee"
;;
arm*)
ARM_VIDEO=yes
@@ -333,6 +334,7 @@ case $host_cpu in
xorg_loader_sparcmuldiv="yes"
SPARC64_VIDEO=yes
BSD_ARCH_SOURCES="sparc64_video.c ioperm_noop.c"
+ GLX_ARCH_DEFINES="-D__GLX_ALIGN64"
;;
x86_64*|amd64*)
use_x86_asm="yes"
@@ -347,8 +349,16 @@ case $host_cpu in
SYS_LIBS=-lamd64
;;
esac
+ GLX_ARCH_DEFINES="-D__GLX_ALIGN64"
+ ;;
+ ia64*)
+ GLX_ARCH_DEFINES="-D__GLX_ALIGN64"
+ ;;
+ s390*)
+ GLX_ARCH_DEFINES="-D__GLX_ALIGN64"
;;
esac
+AC_SUBST(GLX_ARCH_DEFINES)
dnl BSD *_video.c selection
AM_CONDITIONAL(ALPHA_VIDEO, [test "x$ALPHA_VIDEO" = xyes])