summaryrefslogtreecommitdiff
path: root/hw/darwin/bundle/Spanish.lproj/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <idr@us.ibm.com>2007-03-28 08:08:04 -0700
committerIan Romanick <idr@us.ibm.com>2007-03-28 08:08:04 -0700
commit2c6d47108880584f1221ff86c6c8947627f9f607 (patch)
tree64a042f58df056433c430fb0c99735d9e8c0904d /hw/darwin/bundle/Spanish.lproj/Makefile.am
parentc4fe1bcce1c1e4822e688959b331b47a051d6e0a (diff)
parent85220446359a75ea2c359b418b4051c04eea739c (diff)
Merge branch 'master' of git+ssh://git.freedesktop.org/git/xorg/xserver into pci-rework
Conflicts: hw/xfree86/Makefile.am hw/xfree86/dri/dri.c
Diffstat (limited to 'hw/darwin/bundle/Spanish.lproj/Makefile.am')
-rw-r--r--hw/darwin/bundle/Spanish.lproj/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/hw/darwin/bundle/Spanish.lproj/Makefile.am b/hw/darwin/bundle/Spanish.lproj/Makefile.am
new file mode 100644
index 000000000..438d0c2bd
--- /dev/null
+++ b/hw/darwin/bundle/Spanish.lproj/Makefile.am
@@ -0,0 +1,36 @@
+BINDIR = ${bindir}
+include $(top_srcdir)/cpprules.in
+XINITDIR = $(libdir)/X11/xinit
+XDEFS = \
+ -DX_VERSION="$(PLIST_VERSION_STRING)" \
+ -DX_PRE_RELEASE="$(PRE)" \
+ -DX_REL_DATE="$(XORG_DATE)" \
+ -DX_VENDOR_NAME="$(VENDOR_STRING)" \
+ -DX_VENDOR_LINK="$(PLIST_VENDOR_WEB)"
+
+resourcesdir = @APPLE_APPLICATIONS_DIR@/XDarwin.app/Contents/Resources
+
+Spanishlprojdir = $(resourcesdir)/Spanish.lproj
+
+Spanishlproj_DATA = \
+ XDarwinHelp.html \
+ InfoPlist.strings \
+ Credits.rtf Localizable.strings
+
+Spanishlprojnibdir = $(Spanishlprojdir)/MainMenu.nib
+Spanishlprojnib_DATA = MainMenu.nib/classes.nib MainMenu.nib/objects.nib
+
+InfoPlist.strings: $(srcdir)/../English.lproj/InfoPlist.strings.cpp
+ $(RAWCPP) $(RAWCPPFLAGS) $(XDEFS) $(CPP_FILES_FLAGS) $< | $(CPP_SED_MAGIC) | $(SED) -e's/__quote__/"/g' > $@
+
+XDarwinHelp.html: XDarwinHelp.html.cpp
+ $(RAWCPP) $(RAWCPPFLAGS) $(XDEFS) $(CPP_FILES_FLAGS) $< | $(CPP_SED_MAGIC) > $@
+
+CLEANFILES = XDarwinHelp.html InfoPlist.strings
+
+EXTRA_DIST = \
+ Credits.rtf Localizable.strings \
+ Localizable.strings \
+ MainMenu.nib/classes.nib \
+ MainMenu.nib/objects.nib \
+ XDarwinHelp.html.cpp