summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0edf904..1a67bdd 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,15 +1,23 @@
lib_LTLIBRARIES = libxshmfence.la
+if PTHREAD
+PTHREAD_SOURCES=xshmfence_pthread.c xshmfence_pthread.h
+endif
+
+if FUTEX
FUTEX_SOURCES=xshmfence_futex.c xshmfence_futex.h
+endif
libxshmfence_la_SOURCES = \
xshmfenceint.h \
xshmfence_alloc.c \
+ $(PTHREAD_SOURCES) \
$(FUTEX_SOURCES)
AM_CFLAGS = $(CWARNFLAGS)
libxshmfence_la_LDFLAGS = -version-number 1:0:0 -no-undefined
+libxshmfence_la_LIBADD = @PTHREAD_LIBS@
libxshmfenceincludedir = $(includedir)/X11
libxshmfenceinclude_HEADERS = xshmfence.h