summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2012-05-08 11:46:58 +0300
committerDaniel Stone <daniel@fooishbar.org>2012-05-09 15:24:50 +0100
commitbdbb3ac455573413822f2314eb3ea9c76165991a (patch)
treeb89e4267ae237dbce6cd09051b256695d5e7d429 /configure.ac
parentf9fa740fd53e3b57374b674527b2a5a55431349b (diff)
makekeys: fix cross-compilation
makekeys must be built with the build-native compiler, not with $(CC) which is the cross-compiler. The only sane way to achieve this seems to be to use a separate Makefile.am for it. This patch fixes the problem apparently caused by: commit b5efe41f190cbb76eb1ca8ddf0c96990ddb83704 Author: Ran Benita <ran234@gmail.com> Date: Sat Mar 24 04:48:31 2012 +0200 Make build non-recursive There is no such thing as makekeys_makekeys_CC in automake. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 04a737c..54bd6a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,5 +114,9 @@ AC_ARG_WITH([xkb_config_root],
[XKBCONFIGROOT="$xkb_base"])
AC_SUBST([XKBCONFIGROOT])
-AC_CONFIG_FILES([Makefile xkbcommon.pc])
+
+AC_CONFIG_FILES([
+ Makefile
+ makekeys/Makefile
+ xkbcommon.pc])
AC_OUTPUT