summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2005-07-09 18:44:14 +0000
committerAlan Coopersmith <alan.coopersmith@sun.com>2005-07-09 18:44:14 +0000
commit3939ac4410446b46071c9d714f4270c12bf904fe (patch)
tree51ec855dea94ae24d7882bd8bfcc0a5b86876e30 /man/Makefile.am
parent19ba9d0df86c688319377467254b9ea9c4b0eccc (diff)
- Since all but one line of all the nls/*/Makefile.am files are identical, move common bits to nls/localerules.in for easier updating and use automake includes to include in all the nls/*/Makefile.am files
- Don't assume $(CPP) can take gcc-only -traditional flag - CPP process man pages as is done in the monolithic tree
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index f5cab4d1..33699593 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -1,4 +1,10 @@
-man3_MANS = \
+# Have to fake out automake by calling our man pages "DATA" since "MANS" won't
+# accept .3x as a valid man page suffix
+
+LIBMAN_SUFFIX=@LIBMAN_SUFFIX@
+libmandir = $(mandir)/man$(LIBMAN_SUFFIX)
+
+libman_SOURCES = \
AllPlanes.man \
BlackPixelOfScreen.man \
DisplayOfCCC.man \
@@ -181,4 +187,15 @@ man3_MANS = \
XmbTextExtents.man \
XmbTextPerCharExtents.man
-EXTRA_DIST=$(man3_MANS)
+libman_DATA=$(libman_SOURCES:man=$(LIBMAN_SUFFIX))
+
+EXTRA_DIST = $(libman_SOURCES)
+
+CLEANFILES = $(libman_DATA)
+
+include $(top_srcdir)/cpprules.in
+
+SUFFIXES += .$(LIBMAN_SUFFIX) .man
+
+.man.$(LIBMAN_SUFFIX):
+ $(RAWCPP) $(RAWCPPFLAGS) $(CPP_MAN_FLAGS) < $< | $(CPP_SED_MAGIC) > $@