summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2019-04-24 12:50:41 +0100
committerAlan Coopersmith <alanc.fdo@gmail.com>2019-06-08 23:58:16 +0000
commit6886d9ba06826785a8ccb312c04ea82b91bb6a25 (patch)
tree81e81c1a42968b12bbcbc3a8037811574e600fee /configure.ac
parenta121b7b0c210efe10bf93453b29050282324c906 (diff)
Use EXEEXT_FOR_BUILD for makekeys
Use EXEXT_FOR_BUILD, to fix cross-compiling where EXEEXT differs from EXEEXT_FOR_BUILD, such as when building for Windows from unix. (Note: As written, this assumes EXEEXT_FOR_BUILD is always empty when cross-compiling. There could be some elaborate autodetection for EXEXT_FOR_BUILD, but for the moment, if you are cross-compiling from Windows to Unix, you'll need to set EXEEXT_FOR_BUILD explicity...)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7426074f..3ca2a6f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,14 @@ if test x"$LDFLAGS_FOR_BUILD" = x; then
fi
AC_SUBST(LDFLAGS_FOR_BUILD)
+if test x"$EXEEXT_FOR_BUILD" = x; then
+ if test x"$cross_compiling" = xno; then
+ EXEEXT_FOR_BUILD=${EXEEXT}
+ fi
+ # If cross-compiling and not provided, assume EXEEXT_FOR_BUILD is empty
+fi
+AC_SUBST([EXEEXT_FOR_BUILD])
+
# Checks for pkg-config packages
# Always required