summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-02 18:19:53 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-02 18:19:53 +0000
commitb9781c0ff8a8cf3bb90249408eea61a27f14f890 (patch)
treea86ba5bb3b940c2d8da924727baa7b31a6366d7f /Makefile.am
parent2f4aca90ccc891a851e83e281172145b601291b1 (diff)
Add explicit all-local targets so Solaris make can build, since it won't
recursively follow the implicit targets (.bdf -> -ISO-8859-1.bdf -> pcf.gz) Fix a couple of remaining GNU-make-isms
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2690885..116a22e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -235,6 +235,8 @@ CLEANFILES = $(font_DATA) $(BUILT_BDF_FILES)
EXTRA_DIST = $(BDF_FILES) autogen.sh
+all-local: $(BUILT_BDF_FILES) $(font_DATA)
+
install-data-hook:
@rm -f $(DESTDIR)$(fontdir)/fonts.scale
$(MKFONTSCALE) $(DESTDIR)$(fontdir)