summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 42fedc8..dfd5680 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,8 +39,11 @@ XORG_DEFAULT_OPTIONS
# Base set of required pkg-config packages
XLOGO_DEPS="sm xaw7 xmu xt >= 1.0 xext x11"
-# Use render & xft2 to draw logo?
+# Ensure pkg-config is initialized, since first call to macros is conditional
+PKG_PROG_PKG_CONFIG
+# Use render & xft2 to draw logo?
+AC_MSG_CHECKING([whether to use render & xft2 to draw logo])
AC_ARG_WITH(render,
AS_HELP_STRING([--with-render], [Use Xrender & Xft2 to draw logo]),
USE_RENDER="$withval", USE_RENDER="try")
@@ -48,6 +51,7 @@ AC_ARG_WITH(render,
if test "x$USE_RENDER" = "xtry" ; then
PKG_CHECK_EXISTS([xrender xft], USE_RENDER="yes", USE_RENDER="no")
fi
+AC_MSG_RESULT([$USE_RENDER])
if test "x$USE_RENDER" = "xyes" ; then
XLOGO_DEPS="xft xrender $XLOGO_DEPS"
@@ -56,6 +60,23 @@ if test "x$USE_RENDER" = "xyes" ; then
fi
AM_CONDITIONAL([USE_RENDER], [test "x$USE_RENDER" = "xyes"])
+# Use XKB to ring the bell?
+AC_MSG_CHECKING([whether to use XkbStdBell])
+AC_ARG_WITH(xkb,
+ AS_HELP_STRING([--with-xkb], [Use XKB to sound bells]),
+ USE_XKB="$withval", USE_XKB="try")
+
+if test "x$USE_XKB" = "xtry" ; then
+ PKG_CHECK_EXISTS([xkbfile], USE_XKB="yes", USE_XKB="no")
+fi
+AC_MSG_RESULT([$USE_XKB])
+
+if test "x$USE_XKB" = "xyes" ; then
+ XLOGO_DEPS="xkbfile $XLOGO_DEPS"
+
+ AC_DEFINE(XKB, 1, [Define to 1 to use XkbStdBell])
+fi
+
PKG_CHECK_MODULES(XLOGO, $XLOGO_DEPS)
PKG_CHECK_MODULES(APPDEFS, xt)