summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-12 20:27:18 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-12 20:27:18 -0200
commit7d5f24fd8182ac6650d4080f74237c8f3773acb4 (patch)
treea5cd07019942a00c39e6087a6d767bfb88a0aba0 /Makefile.am
parente66bb8c9fb0678cb1086320f931d805491b747f7 (diff)
Ansification and compile warning fixes.
This also uses XORG_CHANGELOG and XORG_CWARNFLAGS, corrects make distcheck and most gcc 4.3 and sparse warnings.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 7 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a36475..1786844 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,31 +45,20 @@ appman_PRE = \
# App default files (*.ad)
-appdefaultdir = @appdefaultdir@
+DISTCHECK_CONFIGURE_FLAGS = --with-appdefaultdir=\$${datadir}/X11/app-defaults
+appdefaultdir = @appdefaultdir@
-APPDEFAULTFILES = \
+dist_appdefault_DATA = \
app-defaults/XClipboard
-SUFFIXES = .ad
-
-.ad:
- [ -d app-defaults ] || mkdir app-defaults
- cp $< $@
-
-appdefault_DATA = $(APPDEFAULTFILES)
-
-EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad)
-
-CLEANFILES = $(APPDEFAULTFILES)
-
appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST += $(appman_PRE)
-CLEANFILES += $(appman_DATA)
+EXTRA_DIST = $(appman_PRE)
+CLEANFILES = $(appman_DATA)
SED = sed
@@ -90,7 +79,7 @@ MAN_SUBSTS = \
-e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
-e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
-SUFFIXES += .$(APP_MAN_SUFFIX) .man
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
@@ -101,6 +90,6 @@ MAINTAINERCLEANFILES = ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog