summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2011-10-14 23:12:05 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2011-10-14 23:12:05 -0700
commit027f85a81df383155e365f160d7760fa50e48ebe (patch)
tree2947ab84d49934ae3cd2cffaaaffeb596a32b2a0 /configure.ac
parent18873da4921369f687023522bc0f07e8e51c8f05 (diff)
Enable the latent XKBStdBell code in oclock
This code has been unreachable since the switch from Imake lost -DXKB, might as well hook it back up. Sadly it relies on the nonsensical use of libxkbfile for the Bell calls, but such is the state of our XKB Bell API. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7fce961..dd1755a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,8 +37,18 @@ XORG_DEFAULT_OPTIONS
AC_CONFIG_HEADERS([config.h])
+# Optional dependencies
+AC_ARG_WITH(xkb,
+ AS_HELP_STRING([--without-xkb],
+ [Disable use of XKB to sound bells (Default is with-xkb)]),
+ use_xkb="$withval", use_xkb="yes")
+if test x$use_xkb != xno ; then
+ XKBMODULE="xkbfile"
+ AC_DEFINE([XKB],1,[Define to use XkbStdBell])
+fi
+
# Checks for pkg-config packages
-PKG_CHECK_MODULES(OCLOCK, x11 xmu xext xt)
+PKG_CHECK_MODULES(OCLOCK, x11 xmu xext xt ${XKBMODULE})
xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
AC_ARG_WITH(appdefaultdir,