summaryrefslogtreecommitdiff
path: root/wm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'wm/Makefile.am')
-rw-r--r--wm/Makefile.am26
1 files changed, 21 insertions, 5 deletions
diff --git a/wm/Makefile.am b/wm/Makefile.am
index 994aec6..9b43a93 100644
--- a/wm/Makefile.am
+++ b/wm/Makefile.am
@@ -6,21 +6,37 @@ lib_LTLIBRARIES = libXCBWM.la
xcbinclude_HEADERS = xcb_wm.h
AM_CFLAGS = -Wall
-INCLUDES = $(XCB_CFLAGS) -I../convenient -I../atom -I../event -I../property -I../icccm
-LDADD = $(XCB_LIBS) \
+
+libXCBWM_la_SOURCES = manage.c table.c
+libXCBWM_la_CFLAGS = $(XCB_CFLAGS) \
+ -I../convenient \
+ -I../atom \
+ -I../event \
+ -I../property \
+ -I../icccm
+libXCBWM_la_LIBADD = $(XCB_LIBS) \
-L../convenient -lXCBAux \
-L../atom -lXCBAtom \
-L../event -lXCBEvent \
-L../property -lXCBProperty \
-L../icccm -lXCBICCCM
-libXCBWM_la_SOURCES = manage.c table.c
-
pkgconfig_DATA = xcb-wm.pc
EXTRA_DIST = xcb-wm.pc.in
noinst_PROGRAMS = xcbwm-test
-xcbwm_test_LDADD = $(LDADD) -L. -lXCBWM -lpthread
xcbwm_test_SOURCES = xcbwm-test.c reply_formats.c reply_formats.h
+xcbwm_test_CFLAGS = $(XCB_CFLAGS) \
+ -I../convenient \
+ -I../atom \
+ -I../event \
+ -I../property \
+ -I../icccm
+xcbwm_test_LDADD = $(XCB_LIBS) \
+ -L../convenient -lXCBAux \
+ -L../event -lXCBEvent \
+ -L../property -lXCBProperty \
+ -L../icccm -lXCBICCCM \
+ -lXCBWM -lpthread