summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Barisione <marco@barisione.org>2011-08-01 16:59:22 +0100
committerMarco Barisione <marco@barisione.org>2011-08-03 14:25:15 +0100
commit3f091f2ff4e97a533142b88f8b8844c53e579ea4 (patch)
tree4c3865bb92c53068512132498742213fe6612092 /configure.ac
parente71f2054f4e6a593b9296ba761fcf6d94c8f980c (diff)
tls: prefer stream ciphers when --enable-stream-ciphers is used
In case this option is used gnutls 2.12.0 is needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6f90c4f..5f0702d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,6 +155,13 @@ AC_ARG_ENABLE([prefer-stream-ciphers],
if test x$prefer_stream_ciphers = xyes; then
AC_DEFINE(ENABLE_PREFER_STREAM_CIPHERS, [],
[Prefer stream ciphers over block ones to save bandwidth])
+ if test $with_tls = gnutls; then
+ # The *-ALL priority strings require gnutls 2.12.0.
+ # We do this check here and not earlier to avoid accidentally falling
+ # back to openssl because of the use of --enable-prefer-stream-ciphers.
+ PKG_CHECK_MODULES(GNUTLS_FOR_STREAM_CIPHERS, [gnutls >= 2.12.0],[],
+ AC_MSG_ERROR([gnutls 2.12.0 is needed to use --enable-prefer-stream-cihpers]))
+ fi
fi
GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`