summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAustin Yuan <shengquan.yuan@intel.com>2009-11-09 09:57:32 +0800
committerAustin Yuan <shengquan.yuan@intel.com>2009-11-09 09:57:32 +0800
commit58f8cc670913b3338181136b5f7a865e0895cc04 (patch)
tree8ec9e6a65dfa5a71f8b6c9890b71f676767d11be /test/Makefile.am
parent49f5210a0aa8d60000a91f69d7f8ad4a682cad53 (diff)
merge master->local-branch-testing2ww46.1-beta-rc220091109_5.1.0.0127
Signed-off-by: Austin Yuan <shengquan.yuan@intel.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 22e2a5d..58e1677 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -27,13 +27,14 @@ bin_PROGRAMS = vainfo
testdir = $(bindir)
-AM_CFLAGS = -I$(top_srcdir)/../../include/external/ -I$(top_srcdir)/src -DIN_LIBVA
+AM_CFLAGS = -I$(top_srcdir)/../../include/external/ -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
TESTS = $(check_PROGRAMS)
-TEST_LIBS = ../src/libva.la
+TEST_LIBS = $(top_srcdir)/src/$(libvabackendlib)
-vainfo_LDADD = ../src/libva.la
+vainfo_LDADD = $(top_srcdir)/src/$(libvabackendlib)
+vainfo_DEPENDENCIES = $(top_srcdir)/src/$(libvabackendlib)
vainfo_SOURCES = vainfo.c
test_01_LDADD = $(TEST_LIBS)
@@ -72,7 +73,7 @@ test_11_SOURCES = test_11.c
test_12_LDADD = $(TEST_LIBS)
test_12_SOURCES = test_12.c
-EXTRA_DIST = test_common.c
+EXTRA_DIST = test_common.c mpeg2-I.jpg mpeg2-I.mpg
valgrind: $(check_PROGRAMS)
for a in $(check_PROGRAMS); do \