summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 43dfd3877..00117e712 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -3,8 +3,14 @@ plugindir = $(libdir)/telepathy/gabble-0
noinst_LTLIBRARIES = \
test.la
+test_la_SOURCES = \
+ test.c \
+ test.h
+
test_la_LDFLAGS = -module -avoid-version -rpath $(plugindir) -lm
AM_CFLAGS = $(ERROR_CFLAGS) @DBUS_CFLAGS@ @GLIB_CFLAGS@ @WOCKY_CFLAGS@ \
@TP_GLIB_CFLAGS@ \
- -I $(top_srcdir)/src -I $(top_builddir)/src
+ -I $(top_srcdir)/src -I $(top_builddir)/src \
+ -I $(top_srcdir) -I $(top_builddir) \
+ -I $(top_srcdir)/plugins