summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2011-03-30 17:54:43 +0200
committerMarc-André Lureau <marcandre.lureau@redhat.com>2011-03-30 18:17:35 +0200
commit3271ebe9bc40dc3e018639effaf8c1a82f018398 (patch)
tree13145a53e3eddb2b75893be7a7de71748a20403d /configure.ac
parent9237548d9a81cda3074769368a09bd7732fc96aa (diff)
gtk/controller: add XPI controller code
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1b4754a..45f379e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,9 +47,11 @@ AC_MSG_CHECKING([for native Win32])
case "$host_os" in
*mingw*|*cygwin*)
os_win32=yes
+ gio_os=gio-windows-2.0
;;
*)
os_win32=no
+ gio_os=gio-unix-2.0
;;
esac
AC_MSG_RESULT([$os_win32])
@@ -198,7 +200,7 @@ PKG_CHECK_MODULES(GOBJECT2, gobject-2.0)
AC_SUBST(GOBJECT2_CFLAGS)
AC_SUBST(GOBJECT2_LIBS)
-PKG_CHECK_MODULES(GIO, gio-2.0 >= 2.10.0)
+PKG_CHECK_MODULES(GIO, gio-2.0 >= 2.10.0 $gio_os)
AC_SUBST(GIO_CFLAGS)
AC_SUBST(GIO_LIBS)
@@ -533,6 +535,7 @@ data/spicy.desktop.in
po/Makefile.in
python_modules/Makefile
gtk/Makefile
+gtk/controller/Makefile
doc/Makefile
doc/reference/Makefile
])