summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2016-06-16 14:40:27 -0400
committerRay Strode <rstrode@redhat.com>2016-06-16 14:40:27 -0400
commit99755d3eaca097a2a51dc5de7402537649d0402d (patch)
tree30cfedd06765b488ef369225096b0046dd5fc6b7 /configure.ac
parentc9a805885ab74cdbb1cb8f988f158540a08132dd (diff)
configure: tweak defaults to be more systemd friendly
systemd is everywhere now, yet we configure by default with non-systemd friendly options. This commit fixes that.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 445034d3..8efdda67 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,7 +117,7 @@ if test x$enable_upstart_monitoring = xyes; then
fi
AM_CONDITIONAL(ENABLE_UPSTART_MONITORING, [test "$enable_upstart_monitoring" = yes])
-AC_ARG_ENABLE(systemd-integration, AS_HELP_STRING([--enable-systemd-integration],[coordinate boot up with systemd]),enable_systemd_integration=$enableval,enable_systemd_integration=no)
+AC_ARG_ENABLE(systemd-integration, AS_HELP_STRING([--enable-systemd-integration],[coordinate boot up with systemd]),enable_systemd_integration=$enableval,enable_systemd_integration=yes)
AM_CONDITIONAL(ENABLE_SYSTEMD_INTEGRATION, [test "$enable_systemd_integration" = yes])
if test x$enable_systemd_integration = xyes; then
@@ -131,7 +131,7 @@ if test x$enable_systemd_integration = xyes; then
AC_SUBST(SYSTEMD_UNIT_DIR)
fi
-AC_ARG_WITH(system-root-install, AS_HELP_STRING([--with-system-root-install],[Install client in /bin and daemon in /sbin]),with_system_root_install=${withval},with_system_root_install=yes)
+AC_ARG_WITH(system-root-install, AS_HELP_STRING([--with-system-root-install],[Install client in /bin and daemon in /sbin]),with_system_root_install=${withval},with_system_root_install=no)
AM_CONDITIONAL(WITH_SYSTEM_ROOT_INSTALL, [test "$with_system_root_install" = yes])
if test x$with_system_root_install = xyes; then