summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-04-05 19:17:25 +0200
committerStef Walter <stefw@gnome.org>2013-05-28 11:18:57 +0200
commitf358242f0068b280c1478075617288095dd95adc (patch)
tree2c574c7484336546686e8872170ebaab50796611 /configure.ac
parent4bd7eda265b94dfcb9a1db4aba756e1e05dd4f87 (diff)
Force Mac OS shared library extension to .so
Darwin and libtool seem confused about what shared library extension they actually use. https://bugs.freedesktop.org/show_bug.cgi?id=57714
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3511800..382c96a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -398,7 +398,17 @@ echo $PACKAGE_VERSION | tr '.' ' ' | while read major minor unused; do
break
done
-eval SHLEXT=$shrext_cmds
+case "$host" in
+*-*-darwin*)
+ # It seems like libtool lies about this see:
+ # https://bugs.freedesktop.org/show_bug.cgi?id=57714
+ SHLEXT='.so'
+ ;;
+*)
+ eval SHLEXT=$shrext_cmds
+ ;;
+esac
+
AC_DEFINE_UNQUOTED(SHLEXT, ["$SHLEXT"], [File extension for shared libraries])
AC_SUBST(SHLEXT)