summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRan Benita <ran234@gmail.com>2012-05-08 14:52:23 +0300
committerDaniel Stone <daniel@fooishbar.org>2012-05-08 17:29:43 +0100
commitb610b2b953be5dcf3983857a2ce0279c2ea86463 (patch)
tree891fad2ac09f9e07db15fad4bbc2806e8ee3ecbd /Makefile.am
parent33273304f2a5526d1fbae0837b0ab58c2dc2db4c (diff)
Rename XKBcommonint.h to xkb-priv.h and use it
Make the files in the src/* directory use their own header or a consilidated private header. This makes the file dependencies clearer. Also drop the pointless "xkb" file name prefix, add split a few declarations to their own files (atom.h and text.h). Signed-off-by: Ran Benita <ran234@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 142796f..008ff40 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,6 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/include \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/xkbcomp \
- -Isrc/xkbcomp/ \
-include $(top_srcdir)/src/config.h
AM_CFLAGS = \
@@ -61,21 +60,22 @@ libxkbcommon_la_SOURCES = \
src/xkbcomp/xkbcomp.h \
src/xkbcomp/xkbcomp-priv.h \
src/alloc.c \
+ src/alloc.h \
src/atom.c \
+ src/atom.h \
src/context.c \
src/keysym.c \
src/map.c \
- src/maprules.c \
src/misc.c \
+ src/rules.c \
+ src/rules.h \
src/state.c \
src/text.c \
+ src/text.h \
src/utils.c \
src/utils.h \
src/xkb.c \
- src/xkballoc.h \
- src/xkbmisc.h \
- src/xkbrules.h \
- src/XKBcommonint.h
+ src/xkb-priv.h
BUILT_SOURCES = \
src/xkbcomp/parser.c \