summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.com>2019-11-04 08:34:38 +0100
committerMiklos Vajna <vmiklos@collabora.com>2019-11-04 08:34:44 +0100
commitcd75e2c5f47f51eee2308abc46b959a362fab59e (patch)
tree55b50867c11cb7701f22548a958ef17b1b56480d /test/Makefile.am
parent2017b7284bbc487f489bfb6374876096537f5c17 (diff)
Convert render shape tests to a new-style one
So that they are in-process, which means it's easier to debug when they fail. Change-Id: I4acbfaa32f6c771d860c0ff2782024b176690ee5
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index fa0fd6524..4907ae898 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -27,6 +27,7 @@ noinst_LTLIBRARIES = \
unit-load-torture.la \
unit-rendering-options.la \
unit-password-protected.la \
+ unit-render-shape.la \
unit-wopi-loadencoded.la unit-wopi-temp.la
MAGIC_TO_FORCE_SHLIB_CREATION = -rpath /dummy
@@ -137,6 +138,8 @@ unit_rendering_options_la_SOURCES = UnitRenderingOptions.cpp
unit_rendering_options_la_LIBADD = $(CPPUNIT_LIBS)
unit_password_protected_la_SOURCES = UnitPasswordProtected.cpp
unit_password_protected_la_LIBADD = $(CPPUNIT_LIBS)
+unit_render_shape_la_SOURCES = UnitRenderShape.cpp
+unit_render_shape_la_LIBADD = $(CPPUNIT_LIBS)
if HAVE_LO_PATH
SYSTEM_STAMP = @SYSTEMPLATE_PATH@/system_stamp
@@ -162,6 +165,7 @@ TESTS = unit-copy-paste.la unit-typing.la unit-convert.la unit-prefork.la unit-t
unit-load-torture.la \
unit-rendering-options.la \
unit-password-protected.la \
+ unit-render-shape.la \
unit-wopi-loadencoded.la unit-wopi-temp.la
# TESTS = unit-client.la
# TESTS += unit-admin.la