summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.com>2019-12-06 08:51:51 +0100
committerMiklos Vajna <vmiklos@collabora.com>2019-12-06 08:51:51 +0100
commitb5f78fe73d9879751492bcfa50b151b95fd33e8c (patch)
tree626e1e55836b9e118b8b93f0fb31e52c87833761 /test/Makefile.am
parentc1788f94f899fe1473a03a5ed165a9215d4bcc02 (diff)
Convert some Calc tests to a new-style one
So that they are in-process, which means it's easier to debug when they fail. Also, in UnitLoad, give up on trying to avoid the sleep after disconnecting, it seems the old condition was not reliable. Change-Id: I972a3319887a70eeea2585104ed1e762830ca505
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 61fd8a142..532c28818 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -33,6 +33,7 @@ noinst_LTLIBRARIES = \
unit-uno-command.la \
unit-load.la \
unit-cursor.la \
+ unit-calc.la \
unit-wopi-loadencoded.la unit-wopi-temp.la
MAGIC_TO_FORCE_SHLIB_CREATION = -rpath /dummy
@@ -158,6 +159,8 @@ unit_load_la_SOURCES = UnitLoad.cpp
unit_load_la_LIBADD = $(CPPUNIT_LIBS)
unit_cursor_la_SOURCES = UnitCursor.cpp
unit_cursor_la_LIBADD = $(CPPUNIT_LIBS)
+unit_calc_la_SOURCES = UnitCalc.cpp
+unit_calc_la_LIBADD = $(CPPUNIT_LIBS)
if HAVE_LO_PATH
SYSTEM_STAMP = @SYSTEMPLATE_PATH@/system_stamp
@@ -189,6 +192,7 @@ TESTS = unit-copy-paste.la unit-typing.la unit-convert.la unit-prefork.la unit-t
unit-uno-command.la \
unit-load.la \
unit-cursor.la \
+ unit-calc.la \
unit-wopi-loadencoded.la unit-wopi-temp.la
# TESTS = unit-client.la
# TESTS += unit-admin.la