summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2022-02-16 17:16:55 +0100
committerStephan Bergmann <sbergman@redhat.com>2022-02-17 18:03:49 +0100
commitfe6043136fd3ba0333b99b8ca4dda699961c2bfd (patch)
tree522f7183ff071e36f7555523f5880169beefebbe /configure.ac
parentfe8ec10eeee51f806392e14440655c8d664bc234 (diff)
Bump Linux Clang baseline to 8.0.1
...as discussed in the mail sub-thread starting at <https://lists.freedesktop.org/archives/libreoffice/2022-February/088476.html> "Also bump Linux Clang baseline to 12.0.1 (was: Bump --enable-compiler-plugins Clang baseline?)", and clean up newly-obsolete __clang_major__ checks Change-Id: Idacb9148b019c07e138277df3a085ba71c64a8e1 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/130028 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4e84f9a33980..ea1db348659c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4326,10 +4326,10 @@ if test "$COM_IS_CLANG" = TRUE; then
CLANG_FULL_VERSION=`echo __clang_version__ | $CC $my_args -`
CLANGVER=`echo $clang_version \
| $AWK -F. '{ print \$1*10000+(\$2<100?\$2:99)*100+(\$3<100?\$3:99) }'`
- if test "$CLANGVER" -ge 50002; then
+ if test "$CLANGVER" -ge 80001; then
AC_MSG_RESULT([yes ($clang_version)])
else
- AC_MSG_ERROR(["$CLANG_FULL_VERSION" is too old or unrecognized, must be at least Clang 5.0.2])
+ AC_MSG_ERROR(["$CLANG_FULL_VERSION" is too old or unrecognized, must be at least Clang 8.0.1])
fi
AC_DEFINE_UNQUOTED(CLANG_VERSION,$CLANGVER)
AC_DEFINE_UNQUOTED(CLANG_FULL_VERSION,$CLANG_FULL_VERSION)